97 Pontiac Grand Prix Electrical/ignition problems

Reply

  #1  
Old 10-12-04, 01:45 PM
97taurusowner
Visiting Guest
Posts: n/a
97 Pontiac Grand Prix Electrical/ignition problems

I have a 97 Grand Prix GT that seems to 'turn off' intermittently. It has turned off at a stop, while at 30-35mph during acceleration and going from moderate breaking to acceleration. The problem accompanies flickering lights from dash and radio and happens if the radio is on or off. Radio still plays as if you turn the ignition from the run to the off position. The radio also seems to have an electrical glitch where the speakers seem to turn off and on. If this plays a part in the ignition/computer problem I don't know.

Vehicle was bought used with 103,250 miles on it.

Any help is greatly appreciated.
 
Sponsored Links
  #2  
Old 10-12-04, 10:22 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Sounds like a loose ground somewhere or a maybe even a bad ignition switch. Make sure both battery terminals are tight and if you have a chassis ground wire from the negative battery cable, it is tight.

The speakers are most likely a different problem. One of the speakers wires may have some insulation exposed and is touching a a metal part of the car when they aren't working or it could be something wrong with the radio itself.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes