95 s10 backup light woes

Reply

  #1  
Old 10-22-04, 11:00 PM
grindall
Visiting Guest
Posts: n/a
95 s10 backup light woes

hello again.
have a s10 with new backup light switch,fuse ok ,bulbs good.still no go.
have meter,what to check?put power accross back wiring direct to one side , opposite bulb does light.any ideas?
thnks
 
Sponsored Links
  #2  
Old 10-22-04, 11:50 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
You need a wiring diagram. Check to see if you're getting power to the fuse. There might be 2 fuses in this circuit, one before the switch, one after the switch. If so, check both fuses. Check for power to the switch. Also, you may have a damaged wire or loose connection at some point along the circuit.

I'm assuming both bulbs lit up when you applied power....you only mentioned that the opposite bulb lit up.
 
  #3  
Old 10-23-04, 07:39 AM
grindall
Visiting Guest
Posts: n/a
thnks,will try and read/follow a wiring route diagram.
wiring never was my fav.
 
  #4  
Old 10-25-04, 06:55 AM
Member
Join Date: Jul 2002
Location: Kansas City, KS
Posts: 588
I have a factory service manual for 95 s-10s. ( I own a 95 s-10 ext cab) I can look it up if you have any questions about what wire goes where. I'm assuming you have a broken wire going to your lights though. Let me know...
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes