78 Mustang II 4cyl was 4speed now c-4

Reply

  #1  
Old 10-24-04, 04:20 PM
stmcdaniel
Visiting Guest
Posts: n/a
78 Mustang II 4cyl was 4speed now c-4

You helped me so much on my 2000 Intrigue I thought I would ask a question for my son. He has a 78 Mustang II with the 4 cyl. It had a 4 speed manual and it was toasted to say the least. My son didn't want to pay 700.00 for another manual so he got a c-4 automatic. The people he got the c-4 from said no problem it would mate up with the 4cyl and included a torque converter and flexplate they got made for this aplication. Question they said the drive line that was used with the manual will work with no problems with the c-4... Whats your view on this whole swap. Does this sound correct or does my son have several other issues to consider. He did get a crossmember from a v8 with c-4 MustII in scrap and new trans mount. Thanks for all your great advice and help, and I did tell my son it would be a dog with the 4cyl and c-4.
 
Sponsored Links
  #2  
Old 10-24-04, 05:58 PM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
well the c4 should work he will need the flex plate crossmember mount vacuum atachments whatever wireing harness needed and speedo cable
the yoke at the trans may need to be replaced if splines are diferant it may be in your best intrest to get the drive shafts from an auto
 
  #3  
Old 10-24-04, 07:48 PM
stmcdaniel
Visiting Guest
Posts: n/a
Question Further Assistance Please

I already have the flexplate, crossmember, torque converter, tranny mount, and dipstick with tube. Does anyone know what electrical harnness or vacuum equipment I will need to hook this up. It's a 78 motor and a 78 c-4 tranny. The speedo cable from the old manual application does anyone know if that will work with the c-4 or if I may need to just change the gear on the end???
 

Last edited by stmcdaniel; 10-25-04 at 08:23 AM.
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes