Losing oil 1993 ford escort

Reply

  #1  
Old 11-12-04, 05:08 AM
Member
Thread Starter
Join Date: Aug 2004
Posts: 59
Losing oil 1993 ford escort

My sons 1993 ford escort 1.9L automatic lost all the oil out of the filter.Thought oil filter wasn't tight or defective.Replaced oil filter and 300 miles later same thing. Anyone had this problem or have any idea why?
Thankyou.
 
Sponsored Links
  #2  
Old 11-12-04, 05:44 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,477
Check to make sure you don't have a double gasket. Sometimes when you remove an old filter the o-ring will stay stuck to the motor and when you spin on the new filter you don't get a good seal becasue of the extra. Beyond that, if it's the right filter and the mounting surface is clean and intact there is no reason to lose oil at thta location.
 
  #3  
Old 11-12-04, 02:27 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
I agree with Towguy but when you remove the old gasket from the block and install yet another new filter start the engine and check for leaks before driving it this time.You should always check for leaks before and after an oil change so you are aware of the situation now instead of later.
 
  #4  
Old 11-13-04, 07:15 AM
Member
Thread Starter
Join Date: Aug 2004
Posts: 59
I checked for old gasket and there wasn.t one. When I put new filter on I tightened it hand tight like before then put filter wrench on it. I turned it easy with the wrench about 1 turn. Maybe the threads where burred and it didn,t go all the way on the first time.
Thankyou for the help.
 
  #5  
Old 11-13-04, 01:16 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
You may be over tightening them,after a filter contacts the block usually it calls for 3/4 to 1 full turn which can be accomplished by hand tightening,well at least I can.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:48 AM.