Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1997 grand caravan


Ren12's Avatar
Visiting Guest

Posts: n/a

11-20-04, 11:39 AM   #1  
Ren12
1997 grand caravan

hello
I have a 1997 grand caravan, 3.3 v-6, with airconditioning. My wife has informed me that the heater is not blowing all the time. Sometimes it will work and others not. I asked if she could feel any heat. She wasn't sure but she said the windshield slowly defrosted. Any ideas. Something cheap I hope.

Thanks,
Rene

 
Sponsored Links
jeff67's Avatar
Member

Join Date: Dec 2001
Posts: 616
NC

11-20-04, 02:45 PM   #2  
Make sure the coolant level isn't low. If the coolant level isn't low, you maybe have a thermostat that is stuck open. Do you have a temperature gauge on the dash? If so, it should be in the normal zone after 10-15 minutes or so after starting the engine. If it shows the engine is cold, when driving the van for a while, the thermostat (and gasket) probably needs to be replaced, which should be easy.

Those are the 1st things you should check.

Also, when is the heater not working? At idle or while driving, or just random times? I assumed the blower is working and its blowing cold air instead of hot air. Is that correct?

 
Ren12's Avatar
Visiting Guest

Posts: n/a

11-22-04, 05:12 AM   #3  
Ren12
Hi jeff
I should have said the blower is not blowing as opposed to the heater not blowing. I apologize for the confusion.

 
trinitro's Avatar
Member

Join Date: Jan 2002
Posts: 1,915

11-22-04, 06:56 AM   #4  
It it's running intermitently then you have a loose connection somewhere. There is probably no easy way to find these....

 
jeff67's Avatar
Member

Join Date: Dec 2001
Posts: 616
NC

11-22-04, 04:51 PM   #5  
Does it operate properly at certain speed settings and not others, like does it work fine in the low speed setting? Or is it intermittant no matter what the speed setting is?

 
Search this Thread