1998 Dodge Caravan 2.4L Cooling fan stays on.

Reply

  #1  
Old 11-28-04, 06:18 AM
Member
Thread Starter
Join Date: Aug 2004
Posts: 59
1998 Dodge Caravan 2.4L Cooling fan stays on.

1998 Dodge Caravan 2.4L automatic A/C.The cooling fan will not shut off even after van is shut off. I have to unplug connection.If I plug it back in even after hours with engine cold still comes on.Temp gauge reads normal.I replaced temp. sensor,didn't help.Anyone have any ideas what to try next?
Thankyou very much.
 
Sponsored Links
  #2  
Old 11-28-04, 07:29 AM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
The easiest thing to check is if the fan relay is stuck on. Locate the relay, (It should be somewhere in the engine compartment in a black box, probably on the driver's side) and pull it out. You will be able to see if the contacts inside the relay are together if its a relay with a clear cover. If you can see the contacts, they should open (separate from each other) when the fan shoud be off or when you pull out the relay. If you see another relay that is the same, pull it out and put it in the fan relay socket. Also check the wires that go to the relay making sure they aren't shorted to any metal part of the van.
 
  #3  
Old 11-28-04, 08:42 AM
Member
Thread Starter
Join Date: Aug 2004
Posts: 59
In the box with fuses and relays there is a fuse marked cooling fan but no relay switch.Would it be somewhere else?
 
  #4  
Old 11-28-04, 09:52 AM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
I found this website decribing the location http://www.faqs.org/qa/qa-22479.html It doesn't look like its as easily accessible as I thought it would be. It also doesn't look like its the clear type of relay.

I also came across this site on a recall related to the relay and pcm. Its for a grand caravan. I can't find any details on it. Best thing to do is call the dealer about it, if no one here knows about it, if you question whether it relates to your van or the problem you're having. http://www.alldata.com/TSB/17/981789EB.html
 
  #5  
Old 11-28-04, 12:14 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
It's a solid state relay and they do have a lot of problems with them. It should be mounted beside the radiator, down low on the driver's side.
 
  #6  
Old 11-28-04, 03:03 PM
david ahluwalia
Visiting Guest
Posts: n/a
Re

They do have a lot of problems ,in fact there was a recall.Or service action? on 1996.Its the relay.Take out the air box and look at the radator,and to the left of it(looking from underneath) up on thcore support you,ll see it.2 screwws
 
  #7  
Old 11-30-04, 08:46 AM
Member
Thread Starter
Join Date: Aug 2004
Posts: 59
I changed the relay with one from salvage yard ,$10.Dealer wanted $82 for new one.Problem solved! Thankyou for all the information! I never would have found problem myself.Again thankyou!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes