Your opinon, 96 GrandAm

Reply

  #1  
Old 11-29-04, 10:51 AM
Trying2Help's Avatar
Member
Thread Starter
Join Date: May 2001
Location: USA
Posts: 715
Question Your opinon, 96 GrandAm

Friend took their car to Jiffy Lube (not my perferred method) to have the oil changed, two weeks ago.
Now the oil light comes on. They have checked the oil level and it is good.

Possible causes?
1. Bad sender
2. Bad oil pump
3. Clogged screen
4. clogged oil filter
5. loose wire

Did I miss anything? If Jiffy Lube doesn't do anything for them, I may be looking at this thing so any help would be appreciated.

What should the oil pressure be on this car? Sorry I don't know what size engine it has, but I am sure it is the most common for this year and make.
 
Sponsored Links
  #2  
Old 11-29-04, 02:35 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Oil sender most likely cause followed by bad bearings(if hi mileage car)overheating thinning the oil.What engine is in the beast and I will quote pressure specs.
 
  #3  
Old 11-29-04, 02:44 PM
Trying2Help's Avatar
Member
Thread Starter
Join Date: May 2001
Location: USA
Posts: 715
I'm going to guess it has the 3.1L six in it. The only other engine is the 2.4L four.

Like I said, I haven't even look under the hood yet so I'm not sure of the engine.

However, if you have both pressures handy.....???????
 
  #4  
Old 11-29-04, 04:19 PM
Trying2Help's Avatar
Member
Thread Starter
Join Date: May 2001
Location: USA
Posts: 715
Yes, I was wrong!!!! It has the 4 banger in it, 2.4L.

He says, "His wife took it back to Jiffy Lube and they couldn't find anything wrong. However, the light is now off." Hmmmmmmmmmmmmm

We will wait and see.

If you have the pressure handy on the 2.4L, let me know. I may go over and check it just to be sure.
 
  #5  
Old 11-30-04, 02:54 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
10 psi @ 900 rpm min and 30 psi @ 3000 rpm min for a 2.4 liter.
 
  #6  
Old 11-30-04, 04:41 PM
Trying2Help's Avatar
Member
Thread Starter
Join Date: May 2001
Location: USA
Posts: 715
Thank you kind Sir.
 
  #7  
Old 11-30-04, 05:01 PM
wrench459
Visiting Guest
Posts: n/a
one other thing that might have happened
the oil pump regulator valve stuck open
I believe theres a TSB on this problem on the quad 4 engine
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes