Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

lights won't work


swgrebel's Avatar
Visiting Guest

Posts: n/a

12-30-04, 04:57 PM   #1  
swgrebel
lights won't work

Hi-I am having a lighting problem with my 1988 Chevy S-10 4x4. First the tailights quit working, now today the headlights won't come on. The brake lights work once in while. Anyone have any ideas what could be the problem?
Changed the fuses and checked the bulbs and they are all fine.
Thanks.

 
Sponsored Links
Desy2820's Avatar
Member

Join Date: Aug 2004
Posts: 539
VA

12-30-04, 05:08 PM   #2  
Not an auto expert, but

I'm thinking that you have more than one problem here.

I'd check for a bad or loose ground connection for the taillight assembly. A bad ground would interfere with all of the lights back there. I'm not sure of the best way to test though...maybe a jumper wire from the outside of a light socket to a good ground point with the lights on?

I'm thinking the headlight problem is something else...maybe a test for a bad switch? Do the high beams work?? Wiggle the switch??

Do you have any test equip... test light, voltmeter... anything like that?


Last edited by Desy2820; 12-30-04 at 05:16 PM. Reason: Info
 
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

12-30-04, 07:21 PM   #3  
question

Do you have a trailor hook up?lots of times due to poor wire hook ups and bad splices you can get problems.

 
jeff67's Avatar
Member

Join Date: Dec 2001
Posts: 616
NC

12-30-04, 08:43 PM   #4  
A bad ground is a good possibilty. Are the turn signal lights and license plate lights working? If you have a trailor wire harness, make sure there isn't any exposed wires or any part of the wires or terminals contacting a metal part of the truck. Also check the the chassis ground wire from the battery to the chassis. Make sure its tight and free of corrosion.

 
Search this Thread