Heat won't Blow

Reply

  #1  
Old 01-05-05, 08:57 AM
ChellDraper
Visiting Guest
Posts: n/a
Question Heat won't Blow

Hi... I need help with my 1996 Chrysler Town and Country minivan. Actually it just needs a big gravesite but I still need to drive it, so I can't do that just yet.

Slowly over the past year or two the high-to-low settings on the heat/a/c blower have just completely stopped. The only one that would work was the very High blower setting. And finally that one keeled over on me last month and when it went out, it took the radio with it. Brrrrrrrrrrr!!!

It has only been six months since I had to have the transmission rebuilt. I took it back then because after I got it back the radio was going in and out. They said a relay switch went bad. I have had several problems with the electric in the past. Could this be another electric problem? Fuse maybe??

My hubby is very non-mechanically inclided and since this is my van I was hoping that this is something I can fix myself. Can anyone tell me what the deal is with this hopeless van??

Kindest Regards,
Chell "Freezin' in Michigan" Draper
 
Sponsored Links
  #2  
Old 01-05-05, 07:34 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Check the radio fuse and blower fuse (not sure if its the same fuse). If you find a bad fuse, turn the blower to off, replace the fuse, see if the radio turns on (if it doesn't, check the fuse again, radio wires may have blown it), then check the blower. A new blower resistor assembly should fix the high to low settings but that may or may not be the reason the blower no longer works at all.

Your owners manual should help you locate the fuse(s).

Never heard of a relay for a radio.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes