Electrical 91 Mercury Sable

Reply

  #1  
Old 01-20-05, 11:52 AM
josephr123
Visiting Guest
Posts: n/a
Electrical 91 Mercury Sable

I am having a problem with the electrical system I believe. One of the leads going to the solenoid switch was broken so I reconnected it figuring that was it.Then the selenoid switch was making a "grinding" noise so we replaced it. My son took the wires apart ( it is his car ) but he believes that they are correct the way we replaced them. Also there is a smell like rotten eggs which seems to come from the solenoid switch when we try to start it. Any thoughts ??
 
Sponsored Links
  #2  
Old 01-20-05, 08:03 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
If you're talking about the starter relay, verify the wiring is correct by going to figure 28 on this page for the wiring diagram: http://www.autozone.com/servlet/UiBr...3d800d3088.jsp
 
  #3  
Old 01-20-05, 08:10 PM
joaa's Avatar
Member
Join Date: Jan 2005
Location: USA
Posts: 47
All the wires go on the battery side of the solenoid except the cable to the starter and a small wire going to the small post on the side. Bets are the rotten egg smell is your battery and needs replaced. Check the charging system for over charge after changing it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes