Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

trailer light problems


rkooy's Avatar
Visiting Guest

Posts: n/a

01-21-05, 10:15 AM   #1  
rkooy
trailer light problems

My utility trailer running lights work; but the turn signals are VERY faint. I can see them blinking, but barely. All the van wiring checks out good.

Any ideas?

 
Sponsored Links
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

01-21-05, 11:08 AM   #2  
Ground

Sounds like you have a ground problem try making a temp ground.Then clen the connections.

 
pgtek's Avatar
Member

Join Date: Oct 2004
Posts: 1,391
CANADA

01-24-05, 07:22 AM   #3  
hi
make sure you have a good ground and change your flasher to Heavy duty
should be ok

cheers
pg

 
kuhurdler's Avatar
Member

Join Date: Jul 2002
Posts: 588

01-24-05, 07:46 AM   #4  
sounds to me like you need to buy a trailer relay kit for your lights. needs more power.

 
rkooy's Avatar
Visiting Guest

Posts: n/a

01-24-05, 11:20 AM   #5  
rkooy
trailer problem solved!

Thanks for the feedback, guys. I discovered the problem: the signal and running lights had been wired backwards. Each bulb has a thin filament (for running lights), and a heavier duty filament (fo signals). So when I turned on a turn signal, the thinner filament would blink (dimly). I switched the wires, and now the signals are brighter,(now that they're wired to the heavier filaments) and the running lights are at normal intensity. Working perfectly.

Thanks again
Rob

 
Search this Thread