95 Grand Am 2.3L stalls after warm-up

Reply

  #1  
Old 01-23-05, 08:11 AM
reyes45's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Michigan, USA
Posts: 71
95 Grand Am 2.3L stalls after warm-up

This Grand Am starts and runs fine but after driving for about 20 minutes it stalls. It starts right up but after 15 or 20 minutes stalls again.
It also stalls in park immidiately after reaching 4000 rpms. Changed fuel pressure regulator,ignition module and tps with no results. Any info is appreciated. Thanks.
 
Sponsored Links
  #2  
Old 01-23-05, 08:21 AM
EclipsemanUSA
Visiting Guest
Posts: n/a
reyes45,

What engine are we talking about the 2.3L or the 3.1L?
 

Last edited by EclipsemanUSA; 01-23-05 at 08:38 AM.
  #3  
Old 01-23-05, 08:52 AM
reyes45's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Michigan, USA
Posts: 71
Grand Am 2.3L stallsafter warm-up

Grand Am is equipted with a 2.3 litter Quad four engine.
 
  #4  
Old 01-23-05, 09:58 AM
EclipsemanUSA
Visiting Guest
Posts: n/a
reyes45,

I would begin with the Idle Air Control (IAC) valve, remove and inspect, be very careful not to bump the pintle needle as it may ruin the worm gear.
 
  #5  
Old 01-23-05, 11:40 AM
reyes45's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Michigan, USA
Posts: 71
shoudn`t the IAC valve trigger check engine light if it was foulty.
 
  #6  
Old 01-23-05, 01:30 PM
EclipsemanUSA
Visiting Guest
Posts: n/a
No, just completed work on a Buick with a stall problem when warm, found to be the IAC with no check engine light.
 
  #7  
Old 01-23-05, 02:16 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
I wouldn't be jumping to those conclusions yet. Start out by cleaning the throttle body, checking the fuel pressure on the highway and checking for any vacuum leaks.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes