Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

95 F150 Will not idle from cold start


dgoode's Avatar
Member

Join Date: Dec 2004
Posts: 114
NJ

01-26-05, 03:57 AM   #1  
95 F150 Will not idle from cold start

95 F150 will not idle from a cold start. The temperature dropped to about 0 degrees and I recently changed the throttle position sensor. Once it was changed it ran fine before the weather dropped. Once the truck is warmed up, it appears to be fine. Any ideas?? Thanks for your help.

 
Sponsored Links
slickshift's Avatar
Member

Join Date: Aug 2003
Posts: 4,320

01-26-05, 04:07 AM   #2  
Did you set/check the voltage on the TPS after the install?

 
hogfan's Avatar
Member

Join Date: Oct 2003
Posts: 352

01-26-05, 04:09 AM   #3  
Clean the throttle body and IAC valve (idle air control valve) Remove negative battery cable for 1 hour at lease if not longer. This makes the computer go into GREEN MODE. Which means it will have to re-learn all settings, such as idle speed.

 
bejay's Avatar
Member

Join Date: Dec 2001
Posts: 2,538

01-26-05, 04:17 AM   #4  
the throttle plates probably needs cleaned start by cleaning any buildup that is just behind the throttleplates and then disconnect the battery for atleast ten minutes and then see how it idles when cold this is a place to start. if it still doesnt idle it may need adjusted or have a bad sensor or iac valve.

 
slickshift's Avatar
Member

Join Date: Aug 2003
Posts: 4,320

01-26-05, 04:18 AM   #5  
Posted By: hogfan Clean the throttle body and IAC valve (idle air control valve) Remove negative battery cable for 1 hour at lease if not longer. This makes the computer go into GREEN MODE. Which means it will have to re-learn all settings, such as idle speed.
Good point
Always unhook the battery to change sensors

 
Search this Thread