92 3.8 won't stay running

Reply

  #1  
Old 01-29-05, 11:47 AM
rushroman
Visiting Guest
Posts: n/a
92 3.8 won't stay running

I have a 92 3.8 in a Buick. When started in the a.m. it will go several miles with no problem. On the return trip 5 hrs later it will stall and won't start for 15-30 min. After that it will start fine. Haven't tested it further. It will start when starting fluid is sprayed in intake. There is fuel @ the fuel rail. When fuel line is removed fuel will pump when engine is turned over. It had the intake man. gasket go bad. I replaced it and all gaskets on top related to intake. It acts like vapor lock. Any ideas?
 
Sponsored Links
  #2  
Old 01-29-05, 01:49 PM
Member
Join Date: Apr 2003
Posts: 174
Take a look at your ignition module, my 3.3 had same problem and that was the cause.
 
  #3  
Old 02-09-05, 05:56 PM
rushroman
Visiting Guest
Posts: n/a
Unhappy Need any other suggestions!


The ICM checked out ok. Will replace the fuel filter next. Any other ideas or suggestions would b appreciated.
 
  #4  
Old 02-10-05, 04:28 AM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Look at the crank sensor and check the fuel pressure with a guage.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 11:29 AM.