ford taurus

Reply

  #1  
Old 02-10-05, 06:09 AM
slgibson
Visiting Guest
Posts: n/a
ford taurus

I have a 1993 ford taurus 3.0 that the front passenger tire squeels when the car is being driven. I changed the wheel barrien (sp) and the axel. When I spray lubricate on the tire it stops squeeling. I can not find out why it squeels and how to fix it permamently. Thanks
 
Sponsored Links
  #2  
Old 02-10-05, 03:36 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
Have you had the wheel alignment checked?
 
  #3  
Old 02-11-05, 04:14 AM
hogfan's Avatar
Member
Join Date: Oct 2003
Posts: 352
check the hub cap.
 
  #4  
Old 02-11-05, 05:13 PM
chuck_zc
Visiting Guest
Posts: n/a
I had a simular problem with a Grand Prix. Checked everything like pads, backing plates,axles etc. just to find out it was a twisted tire. Wasn't really noticable but upon further investigation the treads looked like a snake belly.
 
  #5  
Old 02-11-05, 06:35 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Swap the front and rear tires, to see if the noise follows the tire. Where on the tire are you spraying lubricant? Check to see if brake pad wear indicator is scraping againt the rotor, I've seen that before, even when the brakes weren't applied.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes