Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

86 Chevy Van - Transmission linkage?


MadDog88's Avatar
Visiting Guest

Posts: n/a

02-11-05, 12:26 PM   #1  
MadDog88
86 Chevy Van - Transmission linkage?

Hey folks- hope someone here can help me out.

I have an 86 chevy conversion van. As I was coming home the other day I stopped to get the mail- after I shifted it back into drive from park it had trouble finding the gear but then was ok after a few seconds. After I got it home and then later restarted it, it will not shift into any gear including reverse. The shift lever mechanism works fine but each gear acts as if the vehicle is in neutral. I checked the transmission fluid level and it appears lower than normal but still ok. I believe this is a problem with the transmission linkage or cable but am not sure and haven't had time to look at it yet. Any advice or suggestions would be much appreciated! Thanks!

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

02-11-05, 02:21 PM   #2  
You can crawl under and inspect the linkage if you like.When in park does it drift like it was in neutral?When in gear will it drift or is it still in locked in park?You could pull the pan and check to see if the rod is still attached to the manual valve in the valve body but I'm guessing you have an internal failure of some sort like the pump.


Last edited by davo; 02-11-05 at 02:31 PM.
 
Search this Thread