Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

94 ranger revving up


butterfingers's Avatar
Member

Join Date: Aug 2002
Posts: 97

02-11-05, 03:53 PM   #1  
94 ranger revving up

Hey guys I need a little help cause im stumped. I have a 94 ranger 4x4 with a 3.0 V6. Its doing this funny thing thats really starting to annoy me. Awhile ago it would tach way up to 3 or 4+ thousand rpm's when you push the clutch in to shift. It doesnt matter which gears your between and if you tap the gas it will just tach higher. The ony thing that will stop it is to let the clutch out and that doesnt usually work or shut it off. When you start it again it will run fine for a minute and then act up again. I took it back to where I bought it and they replaced the idle air control sensor with a used one off a taurus. So i drove it and it worked fine for a couple of weeks then it did it again. So I looked under the hood and there was a rock in the throttle linkage so i took that out and it ran fine for a month. Now it is doing it again and I dont have a clue what it is. Any ideas anyone??? Thanks

 
Sponsored Links
hogfan's Avatar
Member

Join Date: Oct 2003
Posts: 352

02-12-05, 04:59 AM   #2  
You need to run a KOER (key on engine run) test on the computer. It will have a code and check back with the code.

 
butterfingers's Avatar
Member

Join Date: Aug 2002
Posts: 97

02-12-05, 01:23 PM   #3  
im taking it to the shop tuesday anyway and they said the check engine light would help them so i assume they will run the test. They said though if i asked anyone else to let them know what i found out and i am just hunting for ideas before i take it in so maybe i will finnaly get it fixed anyone got any ideas??? Thanks

 
Search this Thread