compression test & tune up

Reply

  #1  
Old 02-22-05, 01:42 PM
Member
Thread Starter
Join Date: Sep 2004
Posts: 238
compression test & tune up

The car is a richly running ’93 Mazda Protégé 1.8 l SOHC w/ 5-spd and 91K mis.

Compression test:

I want to do a compression test, but I have read in these pages that only a fool would remove a sparkplug from a hot aluminum head. I always assumed you did a compression test on a hot engine. How is this done?

What do I do with the ignition? Should I ground the fat wire that goes into the middle of the distributor?

What about the fuel pump? Is disabling the fuel pump worth the trouble? I never diconnected fuel to a carb. while doing this.

Tune-up:

The car has a repainted junkyard hood, so the timing, idle speed, plug gap and hose routing labels are all missing. The parts person told me the plug gap should be .040”. Please let me know what the timing and idle should be.

Can I connect an analog tach/dwell meter to this car?

Is the idle adjusted with the bypass airscrew adjacent to the throttle valve? This set-up looks almost identical to my long-gone fuel-injected ’69 VW Squareback. I assumed modern cars had non-adjustable idles.

Should I put dielectric grease on the rotor tip? I have installed some caps that include a small tube in the box. This one did not. Should I do it?

Thanks for the input.
 
Sponsored Links
  #2  
Old 02-22-05, 03:31 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,477
Check autozone.com for general information and maintenance procedures:

http://www.autozone.com/servlet/UiBr...Parameters=019


Any reason why you want to do a compression test? In any event the difference between doing it hot and cold isn't that significant.

Once the plugs are out, doesn't make much difference what you do with the ignition (except stay away from the plug wire ends).

Pull the fuse for the fuel pump. Not absolutely necessary, but probably a good idea (with a carbureted engine no fuel is introduced into the cylinders unless there is vacuum in the manifold; there would be very little with only one cylinder closed since you do a compression test with ALL the spark plugs out and your test guage in one cylinder at a time).

Use the grease if it's included; don't sweat it if it's not.
 
  #3  
Old 02-22-05, 07:37 PM
Member
Thread Starter
Join Date: Sep 2004
Posts: 238
Tow Guy-compression test

I'm doing all this because the car just barely passed emission test last year with high HC. At low idle it had 200 ppm with up to 220 allowed. A few years ago it would have values like 13 ppm. I'll do an oil change just before it is tested and I already put in a new air filter.

I'll do the test w/ a stone cold engine and ground the big wire coming out of the coil.

It seems to also have a lot of blow by with oil being blown backward through the breather and coating the throttle w/ oil. I have checked the pcv system but it cannot handle the volume. I don't know if this is enough to push up HC.

I got 5 degrees for time from the Autozone site. I assume that is BTDC. Nothing about idle. The tach in the dash has idle at about 700-750. As far as I know the distibuter position has never been touched, so it should be ok. I just thought I would check.

Maybe an unrelated detail is that I have a lot of lifter noise, but I hear that is common w/ this vintage Mazda.

Thanks
 
  #4  
Old 02-23-05, 05:07 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,477
Emissions are not my strong point, but I would assume excess blow-by would contribute to the HC reading.
 
  #5  
Old 02-23-05, 05:30 AM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
sounds like worn out rings

Lots of blow by sounds like worn rings is the oil getting to the air filter?How many miles do you have?Try this start car and remove the cap were you put the oil is it pushing a lot of air out if so that is not a good thing.
 
  #6  
Old 02-28-05, 08:05 AM
Member
Thread Starter
Join Date: Sep 2004
Posts: 238
blow-by

No oil is making it to the air filter, but the throttle valve and I asume all the smaller passages that control idle get covered with oil.

I held a paper towel over the oil filler hole at idle the towel was pushed out. At high rpms the towel was sucked into the hole. Is this what you would expect to find?
 
  #7  
Old 03-02-05, 03:43 PM
Member
Join Date: Aug 2003
Posts: 478
If you want to do a hot compression test I would take the plugs out cold. Put anti sieze on them and reinstall but just put them in snug making sure they screw in easily. If not run them in and out a couple of times to get the anti sieze on the threads in the head. Then you can run the engine get it hot and the plugs should come right out.

Taking plugs out of a hot aluminum head can pull the threads if they are tight and if they did not have anti sieze on them.
 
  #8  
Old 03-10-05, 11:59 AM
Member
Thread Starter
Join Date: Sep 2004
Posts: 238
Car Nut

I CANNOT GET NO. 4 PLUG OUT. IT STARTED TURNING BUT THE RESISTANCE INCREASED AS I TURNED. I TRIED WORKING IT IN AND OUT BUT I GAVE UP. I FIGURED IF I GOT IT OUT THEN I WOULD NEVER GET IT BACK IN. THE OTHER 3 LOOKED FINE WITH NO REAL INCREASE IN GAP. I SHOULD EASILY BE ABLE TO GO A 100k ON THE CHEAP PLUG BEFORE THE GAP IS TO BIG.

MAYBE THE PLUG GOT CROSS THREADED.

ANYWAY, I GAVE UP ON THE COMPRESSION TEST. I'LL JUST DRIVE IT UNTIL THE TIMING BELT BREAKS AND WALK AWAY.
 
  #9  
Old 03-11-05, 06:34 PM
Member
Join Date: Aug 2003
Posts: 478
Don't give up so easy. Unscrew it as far as it will reasonably go but don't force it. Put some good penetrating fluid at the base of the plug. Let it sit for a few minutes. Put a little more on and screw the plug back in just snug. Then back it out & repeat a few times. Hope fully it will come a little further each time. If you can't get it out with out forcing it put some fluid at the base & screw it back in nice & snug. Take the car out and drive it. Then try it again when the engine is cold. You may have to do this process several times. Just take your time & be patient. I bet it will eventually come out.

I doubt if it was cross threaded particularly if it was screwed all the way in. Some one may have over tightened it and started pulling the threads. But more likely it is corroded because someone did not use anti sieze on it.

When you get it out put some anti sieze on the new plug and smear a little inside the threads in the head. Don't over do it. Run the plug in & out a few times to be sure the threads are well coated. Just be sure you don't use so much that uou get it on the electrodes as it will shout the plug out.
 
  #10  
Old 03-14-05, 07:19 PM
Member
Thread Starter
Join Date: Sep 2004
Posts: 238
car nut

Thanks for the tip. I will try it.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:44 AM.