95 prism will not go

Reply

  #1  
Old 03-13-05, 08:17 AM
cookie2cute
Visiting Guest
Posts: n/a
95 prism will not go

Hi there....I have a big problem that I am hoping you can at least give me a clue as to what in the heck is going on...I have a 95 prism automatic transmission 4 cyl with 65,00 miles on it...It ran absolutely wonderful till about a week ago at which time there was some squeling going on..sounded like maybe the fan belt or something but that seemed to be ok...So now all of a sudden it simply doesnt move...I put it in drive and I just rev my engine . Same thing in reverse and all other gears...It doesnt move...I do remember a couple of days ago when I was driving at about 40mph it kinda felt like it was dragging a bit....like maybe I had my emergency brake on or something..Does anyone jhave any idea what this could be? I really would like to at least have a starting point ...Thank you much
 
Sponsored Links
  #2  
Old 03-13-05, 08:23 AM
lewashi
Visiting Guest
Posts: n/a
sounds like you better check the transmission fluid level and see if you have any....if there is anything on the dipstick you may want to make a mental note of what color the fluid is and if there is any metal flakes...it's probably too low so you will probably need to add some...a pint (half a quart) at a time until you get it back to full on the dipstick. It may not fix the problem if the tranny is damaged enough but it won't hurt and you may get lucky.
 
  #3  
Old 03-13-05, 08:46 AM
cookie2cute
Visiting Guest
Posts: n/a
Hi..Yhank you for the quick response...I am going right now to check the tranny fluid ...I will be sooooo happy if you are right...Will let you know
 
  #4  
Old 03-13-05, 08:52 AM
lewashi
Visiting Guest
Posts: n/a
Arrow

no problem...if by chance/luck it works I would also suggested you/someone figure out & fix whatever is squealing...the why of it is that it may well keep you from the side of the road, especially if it's the alternator belt
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes