1990 Lincoln Mark IIV HARD BRAKES

Reply

  #1  
Old 03-16-05, 06:54 AM
smittysweep
Visiting Guest
Posts: n/a
1990 Lincoln Mark IIV HARD BRAKES


Brakes work fine 99% of the time but during a panic stop brake petal will get hard and it feels like I am only getting about 50% of braking and car will pull to one side. If you let off of the brake after attempting a panic stop and then apply brake again it works fine. I took it to the dealer and was told it was the accumulator. I pulled 2 from a salvage yard but problem still exists. Have had this problem for 3 years and am unable to get any information on this to fix brakes completely. I have taken it for a drive and tried to do the panic stop but it will not do the hard petal consistantly. Any ideas?
 
Sponsored Links
  #2  
Old 03-16-05, 09:49 AM
carguyinva's Avatar
Member
Join Date: Nov 2003
Location: Shenandoah Valley
Posts: 1,147
is it...

...equipped with ABS brakes? if so, what make and version?? it may be characteristic. when you say accumulator, that sounds like an ABS part to me...could you be referring to the brake booster if it's not ABS? if so, you may have a bad vacuum check valve which is located in the vacuum line right where it attaches to the top of the booster.
 
  #3  
Old 03-16-05, 04:54 PM
smittysweep
Visiting Guest
Posts: n/a
hard mark 7 brakes a panic stops

yes abs brakes no brake booster has a pump no check vavle hydro boost any more info would appriciate
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:56 AM.