1992 Chev S-10 Blazer 4X4 tranni probs

Reply

  #1  
Old 03-26-05, 06:24 PM
BullTiger
Visiting Guest
Posts: n/a
Cool 1992 Chev S-10 Blazer 4X4 tranni probs

1992 Chevy S-10 Blazer 4 door 4.3L 4X4 transmission


Lately I have been noticing that when driving on the highway, shifting into 3rd seems to be a problem, seems like it is winding out, have to put truck in Over Drive for it to shift. Then tonight when I put truck in drive and started to go forward, there was whurring sound then there was a loud bang, almost sound like I was missing a gear or slipped a gear even, but nothing seemed to happen after that. Made it home safe Automatic transmission by the way. Not driving in 4 wheel just in 2 wheel drive...any ideas?
 

Last edited by BullTiger; 03-26-05 at 06:35 PM. Reason: not enough info
Sponsored Links
  #2  
Old 03-27-05, 06:41 AM
bust7015's Avatar
Member
Join Date: Jul 2001
Location: Connecticut
Posts: 110
When you say you made it home safe, do you mean the trans acted fine after the bang? Have you had the truck plugged in to diagnose it? Without kinowing the habit. I would say you had a stuck ball in the valve body causing the missed shift. It probably broke loss and the bang was a clutch pack, a band breaking or worse. Take it to a tranny shop. Most still diagnose for free.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes