67 Gmc

Reply

  #1  
Old 04-01-05, 05:09 PM
Member
Thread Starter
Join Date: Oct 2004
Location: USA
Posts: 139
67 Gmc

I have a '67 GMC truck, and it's not charging the battery, the battery is new. the alternator in charging correctly, I changed the voltage regulator, the started is new too; please help me out if you have any ideas what could be wrong. Thanks in advance.
 
Sponsored Links
  #2  
Old 04-01-05, 05:22 PM
Lugnut's Avatar
Member
Join Date: Jan 2001
Location: Kansas City, Missouri.
Posts: 1,172
These old v-belts again,,, sorry guys, but this kind of charging problem can be hard to diagnose and pinpoint and that is why I say it all the time. REPLACE THE BELT.

You say all is good; the battery, the alternator, cables, the regulator, so....change that old glazed belt!!!! Yeah, I know, it looks new, but it's not. V-belt glazing happens but is seldom accurately diagonosed because people change the belt with the alternator at any shop, but at home, they use the old belt. Until you change the belt, you will never know.
 
  #3  
Old 04-01-05, 09:32 PM
comp's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Mar 2005
Location: So. IN.
Posts: 76
is it charging any ???? check all the wire connection's
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes