Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

The radio in my 1993 dodge caravan wont work


theplumber419's Avatar
Visiting Guest

Posts: n/a

04-02-05, 01:04 PM   #1  
theplumber419
The radio in my 1993 dodge caravan wont work

I have a broken radio in a 1993 dodge caravan, the radio wont play any sound does anybody have any ideas how to fix it let me know thnxs

 
Sponsored Links
unclejack's Avatar
Member

Join Date: Jan 2005
Posts: 302
PA

04-02-05, 03:15 PM   #2  
Posted By: theplumber419 I have a broken radio in a 1993 dodge caravan, the radio wont play any sound does anybody have any ideas how to fix it let me know thnxs
What I think would be good idea would be for you to just go to a u-pull it type junkyard and get one there. That way you learn how to remove it, thus making re-instalation a lot easier!! If you break something it's not really that important being it's already in a junkyard! Radios around here are plentiful and only $10 , $20 with the tape deck.

 
Kestas's Avatar
Member

Join Date: Oct 2000
Posts: 923
MI

04-02-05, 05:30 PM   #3  
That, or eBay. There's a lot of people who upgrade their sound systems and want to convert their unneeded radio to cash.

 
jeff67's Avatar
Member

Join Date: Dec 2001
Posts: 616
NC

04-03-05, 08:26 AM   #4  
Check for a lose speaker wire harness connection or you may have one of the speaker wires shorting to ground. If you have some other speakers laying around, you could try making a temporary connection to those to determine if the problem is with the stereo.

 
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

04-03-05, 10:00 AM   #5  
does it light up

does it light up?If not it might be a fuse.If it lights up check all speaker connections if still no sound replace radio.

 
theplumber419's Avatar
Visiting Guest

Posts: n/a

04-06-05, 09:34 PM   #6  
theplumber419
ive checked all of the connections and tried other speakers with it, and it does light up, thats the first thing i did was check the fuse but it still wont work thnx for the comments though

 
Search this Thread