Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1997 Ford Aerostar Speedometer


ron21's Avatar
Member

Join Date: Jan 2005
Posts: 18

05-06-05, 06:29 PM   #1  
1997 Ford Aerostar Speedometer

I have a 1997 Ford Aerostar van with the 3.0 L Engine-automatic Transmission aprox 228K on it. Lately the spedometer has started to act up It will quit for a couple of minutes then start working again. I can't seem to find the cable that goes from the transmission to the dash. Also the wife has said she has heard a clunk when this happens although I have not heard it myself.

Any ideas what may be causing this?

Thanks in advance

 
Sponsored Links
pgtek's Avatar
Member

Join Date: Oct 2004
Posts: 1,391
CANADA

05-09-05, 06:33 AM   #2  
hi
sound like broken cable in the casing.
check your dealer how to repair it or buy a mechanical book on your make

cheers

 
hogfan's Avatar
Member

Join Date: Oct 2003
Posts: 352

05-09-05, 10:40 AM   #3  
ron21,
This has a Programmable electric analog speedometer (PSOM) receives its input from the anti-lock brake sensor. Is the anti-lock brake light on?
This speedometer is only service as an instrument cluster assembly.

 
hogfan's Avatar
Member

Join Date: Oct 2003
Posts: 352

05-09-05, 10:42 AM   #4  
Sorry, I forgot to say there is no cable.

 
ron21's Avatar
Member

Join Date: Jan 2005
Posts: 18

05-10-05, 07:04 AM   #5  
No anti brake light on.
I have a feeling the contacts may be coroded on the transmission. Seems to be worse in the rainy weather. Going to have a look today

 
Search this Thread