speedometer cable problem

Reply

  #1  
Old 05-14-05, 06:54 PM
leostar
Visiting Guest
Posts: n/a
speedometer cable problem

I drive a 93 Chevy Blazer and the speedometer cable is stuck....it stuck at exactly 55 mph.....from time to time it would correct itself..this was during the winter...but now it stays at that reading all the time. Can anyone suggest a cure? I would appreciate it...so far I have been "lucky" guessing what my approximate speed actually is....but that won't last! Hope to hear from someone soon
 
Sponsored Links
  #2  
Old 05-15-05, 09:00 AM
Member
Join Date: Aug 2003
Location: Barre,Vermont
Posts: 472
You're pushing my memory here, but that has no cable, it's an electronic speedo. If it's stuck at 55, it sounds like the speedometer itself has failed internally, and that a new one is going to be in order.
 
  #3  
Old 05-16-05, 03:21 PM
Hirsch's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Mar 2003
Location: Southeastern Connectitax
Posts: 167
Too bad!! If it was a cable speedo, all you would have to do is take the instrument cluster out, disconnect the speedo cable, shoot some powdered graphite down it, and put it back together.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:32 PM.