s10 blazer 92 ac problem

Reply

  #1  
Old 05-21-05, 11:36 AM
moradnasr
Visiting Guest
Posts: n/a
Question s10 blazer 92 ac problem

I have a blazer 1992 s10 . My ac works for 15 minutes then stops cooling the air . the blower blows normal air (not cold) .somtimes it picks up again cold air for 5 minutes and stops blowing cold air tell the car stops for an hour at least then repeet the problem again. is it a leackage of the freezing againt or what?
thanks
Morad
 

Last edited by moradnasr; 05-21-05 at 11:41 AM. Reason: help
Sponsored Links
  #2  
Old 05-21-05, 01:08 PM
Member
Join Date: Apr 2005
Posts: 242
got to put some gauges on there to see if its low on freon. If psi is ok then is compressor running when it stops cooling? if so it might be a bad psi switch.
 
  #3  
Old 05-22-05, 04:58 AM
Member
Join Date: Aug 2003
Location: Barre,Vermont
Posts: 472
It sounds like the evaporator is freezing up.
while it's cooling properly, observe the compressor clutch. It should cycle off, and then on. The frequency of the cycling depends on ambient temperatures and fan speed and engine speed. If it's real hot outside, and the fan is on high, the compressor on time should be long, like 45 seconds, then cycle off for say, 20 seconds. If it doesn't cycle off, the water condensing on the evaporator will freeze, causing loss of cooling(and air flow too)
 
  #4  
Old 05-25-05, 08:19 PM
Member
Join Date: May 2005
Posts: 93
check the relay it may be bad it should be located on the driverside fire wall one is the fuel pump and the other for the ac
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'