why aren't my signal lights working?

Reply

  #1  
Old 06-14-05, 11:11 AM
spidergirl
Visiting Guest
Posts: n/a
why aren't my signal lights working?

i have a 90 t-bird that's been giving me one headache after another, the latest being that my signal lights worked occasionally for about 2 weeks, then totally quit on me the other day. it's not the fuse, and can't be a burnt bulb because it affected both sides every time. at times i can hear a buzz from something in the steering column when i try to use them & when i pull/insert the fuse, and i've poked around in there to see if there's a loose wire but no luck. there is still some sort of connection because the cornering lamps still work. if anyone could give me some advice on what it may be i'd truly appriciate it. i've become one of those jerks i swear at that don't use a turn signal!
 
Sponsored Links
  #2  
Old 06-14-05, 02:28 PM
Member
Join Date: Dec 2001
Posts: 2,538
Received 0 Votes on 0 Posts
could be a bad signal switch if they dont even light up, you may need to see a shop for testing or a good wiring diagram of the switch and a test light and test the switch yourself.
 
  #3  
Old 06-15-05, 05:53 PM
spidergirl
Visiting Guest
Posts: n/a
got them working & thankfully it was indeed only the flasher. $22 new (this model has a combined hazard/signal flasher. brilliant o.O ) compaired to $318 for a switch... ~phewf~
thanks for your input.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: