fuel pump

Reply

  #1  
Old 06-19-05, 06:18 PM
bytesnooper
Visiting Guest
Posts: n/a
fuel pump

What would make the fuel pump make a high pitched noise as soon as the ignition is Turn on. It never made any noticeable noise before, now itís really load. But Iím Getting fuel. ? There has to be some mechanics around that can
answer this or someone that has had this problem.
Missed to explain very some detail. When the ignition switch turned on without starting the engine the fuel pump doesn't stop running after about a second. Keeps running ?

3.0 L ford aerostar
 

Last edited by bytesnooper; 06-20-05 at 04:17 AM.
Sponsored Links
  #2  
Old 06-20-05, 05:19 AM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Originally Posted by bytesnooper
What would make the fuel pump make a high pitched noise as soon as the ignition is Turn on. It never made any noticeable noise before, now itís really load. But Iím Getting fuel. ? There has to be some mechanics around that can
answer this or someone that has had this problem.
Missed to explain very some detail. When the ignition switch turned on without starting the engine the fuel pump doesn't stop running after about a second. Keeps running ?

3.0 L ford aerostar
Originally Posted by bytesnooper
Previously my aerostar was starting o.k running rough and black exhaust fouling the
Oxygen sensor exhaust pipe. So I cleaned the MAF sensor. Replaced the Throttle position sensor, air bypass sensor, oxygen sensor and replace the fuel pressure reg. cleaned ever connector I could find and the engine still wonít run.

Now it wonít start and when I turn the ignition on, the fuel pump is making a loud
Whining noise. ? The pump never made noise before but canít see how the engine is
Fouling if there is a problem with the fuel pump.

No codes
Just checking here....
Previously it had a rich condition, rough running, black tail-pipe
Now it's a no-start with noisy Fuel Pump
 
  #3  
Old 06-20-05, 07:19 AM
bytesnooper
Visiting Guest
Posts: n/a
fuel pump continued HELP

Yes. I just relaized that the fuel pump noise is normal. It would normaly
shut off in less then One second when the ignition switch is turned to
run without starting the engine, Now it keeps running ? This morning I took the gas cap off thinking that the tank is not venting and the turned the ignition on and the pump acted normal now. Made a whining sound for less
then a second then stopped ? Don't know if this is an intermittent
condition ?

Well this condition is intermittent. Tried it at the end of the day and
its back staying on continuously when the ignition is turned on.

What controls this

if it acts right the engine starts. If it stays on making the noise engine will
not start.
 

Last edited by bytesnooper; 06-20-05 at 02:08 PM.
  #4  
Old 06-21-05, 04:15 AM
bytesnooper
Visiting Guest
Posts: n/a
Fuel pump

Going for the Computer. It could cause the rough idle and rich condition when the engine does start. Oxygen, throttle position,air bypass,cleaned Maf and replaced fuel reg. Didn't make any difference. also can't read codes from the
computer and it could cause the fuel pump to stay on continuously most of the time when the ignition is turn on. I'm not a mechanic. I can replace anything that goes bad on a car ,but I don't work every day troubleshooting engine of electrical problems. If any mechanics have any suggestions I would
like to here from you.. thanks
 
  #5  
Old 06-21-05, 04:31 AM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
I think you have a Schrader valve (looks like a tire stem you put air in) on a fuel rail that's easily accessable
If you could hook up a fuel pressure guage (some DIY autozone type places have loaner programs) I'd check that first

A fuel leak, leaky injectors, a bad fuel pump (stuck on), a failed fuel pressure regulator, all things things could be causing or adding to you're problem

I'd check these before replacing the computer
And replacing the computer won't solve any of these problems
 
  #6  
Old 06-21-05, 12:37 PM
bytesnooper
Visiting Guest
Posts: n/a
fuel pump continued

thanks for the reply. Already picked up a computer for $50. I have
to know if its the computer. I am going to connect it tonight. Hope it
changes or fixes the problem. From what I can see the computer controls
when this fuel pump relay gets turned on and off. Hope it doesn't turn out to
be a fuel pump. I really don't want to change the fuel pump.

I can bring the computer back with no charge to me if
it doesn't fix anything. I changed almost every sensor and fuel regulator
and was able to return everyting except the Fuel pressure reg. so I'm
not into this van for very much so far. I really want to fix this van.
had it a long time and until this part some where failed it was running
great.
 
  #7  
Old 06-21-05, 01:08 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Good luck!
Hope it works!
 
  #8  
Old 06-21-05, 05:11 PM
bytesnooper
Visiting Guest
Posts: n/a
92 aerostar running rich/stalling/fuel pump on all the time



Yes, this is a great day. I changed the computer and baby this vans
running like new. Ford wanted $250 for a computer, the junk yard wanted $50 didn't know if this would do it ,so decided on the 50 bucks.

To everyone that replied to me thanks for your help.
 
  #9  
Old 06-21-05, 07:30 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Thumbs up

That's great!
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:00 AM.