97 elantra brake problems

Reply

  #1  
Old 07-03-05, 08:06 AM
candz
Visiting Guest
Posts: n/a
97 elantra brake problems

i just changed the front pads and rear pads and calipers on 97 elantra w/ 4 wheel abs disc brakes. Everything seemed to go fine, but when i bled the system, i still can't get any pedal. What could i have done wrong? Any help would be appreciated..
 
Sponsored Links
  #2  
Old 07-03-05, 08:53 AM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Originally Posted by candz
i still can't get any pedal.
Explain what you mean by this. This pedal is hard or it goes all the way to the floor? Did you have this problem before you changed the pads? It might be a brake hose collasped internally. Did any fluid come out when you bled the brakes?
 
  #3  
Old 07-03-05, 09:12 AM
candz
Visiting Guest
Posts: n/a
by no pedal I mean it goes all the way to the floor and this wasn't happening before I changed the brakes. When I bled the lines, fluid came out from each bleeder screw. Thanks for any help
 
  #4  
Old 07-03-05, 09:43 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Make sure the brake fluid level is normal and you haven't left a bleeder screw loose and you dont see any fluid leaking near the calipers.
 
  #5  
Old 07-04-05, 06:00 AM
candz
Visiting Guest
Posts: n/a
the fluid level is good, and there are no leaks detectable. i am going to try to bleed them again. maybe there is air trapped in the hose somewhere. the rear calipers were off the vehicle for a couple of days waiting for the new ones, thanks for your help.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes