gauges wrong, car dead

Reply

  #1  
Old 07-10-05, 03:29 PM
Member
Thread Starter
Join Date: Oct 2001
Posts: 20
gauges wrong, car dead

We have a 2001 Toyota Avalon. It operated normally earlier in the day. Later, on turning the ignition, nothing happened. The tachometer and speedometer needles are at 11:00: the engine temperature and gas guages are pointing straight up. Should we attempt to jump the car? Does the gauge problem indicate some other electrical or computer problem? Would you have the car towed to the dealer?
 
Sponsored Links
  #2  
Old 07-10-05, 03:59 PM
BuzzCut
Visiting Guest
Posts: n/a
Possible faulty battery connections. Clean and try starting it. If the battery is original I would look at the replacement of it. The guage problems are probably due to the fact the battery is dead or the connections have a ton of corrosion on them thus no power to them.

Originally Posted by Jill of all trades
We have a 2001 Toyota Avalon. It operated normally earlier in the day. Later, on turning the ignition, nothing happened. The tachometer and speedometer needles are at 11:00: the engine temperature and gas guages are pointing straight up. Should we attempt to jump the car? Does the gauge problem indicate some other electrical or computer problem? Would you have the car towed to the dealer?
 
  #3  
Old 07-11-05, 06:43 AM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
yep battery

I would also suspect the battery 2001 I am thinking original battery.These new cars are very unforgiving with faulty batterys they do all kinds of strange things.I would go to the battery first and like said clean posts and start looking at a new battery.4 years is about average life span.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'