Suburban, rear a/c

Reply

  #1  
Old 07-14-05, 08:57 AM
Blasterjdh
Visiting Guest
Posts: n/a
Question Suburban, rear a/c

The rear A/C unit of my 1995 Chev Suburban does not work. I have powr to the controls mounted above the rear seating. This situation occurred when a friend wired the trailer hitch - just stopped working after that. Is there an additional in-line fuze or something. Any help would be apprciated...
 
Sponsored Links
  #2  
Old 07-14-05, 01:27 PM
Member
Join Date: Dec 2001
Posts: 2,538
could you be more specific do you hear the blower working feel any air coming out or does it blow air but its just not cold?
if its blowing air is the air in the front working ok?
 
  #3  
Old 07-14-05, 02:44 PM
Blasterjdh
Visiting Guest
Posts: n/a
The front A/c works great - The back blower does not work and I can not feel any A/c at all - I checked at the control switch just above the rear seat - it had power to the switch - other than that I do not know what to do to diagnos the problem---Help---Thanks in advance
 
  #4  
Old 07-16-05, 03:43 PM
Blasterjdh
Visiting Guest
Posts: n/a
An update - I located the rear a/c fan - Located under the right rear quarter panel - I check and found NO power to the unit in the rear... I checked the wiring diagram and it does not show any additional in-line fuzes other than the one under the dash -- Is there a "fuzable link" wire for the a/c - -- I am lookin for any help that you could give... Thanks
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'