Please Help Me (Battery or fuse problem)

Reply

  #1  
Old 07-14-05, 07:09 PM
BIGGMIKE3615
Visiting Guest
Posts: n/a
Angry Please Help Me (Battery or fuse problem)

i HAVE 97 FORD TAURUS THAT HASN'T BEEN DROVEN IN A WHILE. ME & MY BROTHER PUT A NEW BATTERY IN THE CAR, ONLY TO FIND THE RADIO, SPEEDOMETER, GAS METER, WIND SHIELD WIPERS, WINDOWS, TAIL LIGHTS AND INTERIOR LIGHTS DOESN'T WORK. IS THIS A FUSE PROBLEM? i CHANGED A COUPLE OF FUSES AND NOTHING HAPPENED. PLEASE HELP ME
 
Sponsored Links
  #2  
Old 07-14-05, 07:40 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Does the car start?
 
  #3  
Old 07-14-05, 10:49 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Does anything work?
If not, make sure the battery cables aren't reversed and the chassis ground, the smaller black wire from the battery to the chassis, is connected and corrosion free and the battery terminals are clean and very tight around the battery posts. Also check the large 175 amp megafuse located in the fuse box in the engine compartment.
 
  #4  
Old 07-16-05, 06:53 PM
Toyota_Doctor
Visiting Guest
Posts: n/a
I would have to agree check the main fuse to see if that's good. Look for anything loose. Check to see if the timing belt is intact. Will the thing turn over? Make sure battery cables are observing polarity ( Neg on Neg Pos on Pos ) Hit me up if you get the beast running, or don't I can help you.


Later,

Bart
 
  #5  
Old 07-16-05, 07:09 PM
Lugnut's Avatar
Member
Join Date: Jan 2001
Location: Kansas City, Missouri.
Posts: 1,172
It almost sounds like the 'accessory' circuit is disconnected, except the tail lights would still be working, but you say they aren't.

As mentioned, I would check the chassis ground. Perform a simple voltage drop test. You should get a 12 volt reading between the positive battery post and the car body.
 
  #6  
Old 07-16-05, 07:16 PM
Member
Join Date: Dec 2003
Location: Indiana
Posts: 312
You need to have the BCM (I think Ford calls it a "Generic Electronics Module") checked for communication/reset. If the car starts and runs, that's the only thing all of those accessories/systems have in common.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'