1993 Mazda 626 Won't hold charge

Reply

  #1  
Old 07-16-05, 07:15 AM
Ray Scott
Visiting Guest
Posts: n/a
1993 Mazda 626 Won't hold charge

I have a 1993 Mazda 626.

I have put in a new battery and alternator.

The battery was fully charged before installation. It held for 2 days.

I've checked all the wiring from the alternator to the battery, I changed the ground cable. Recharged battery at Auto Zone, still will only last two days.

Why is my charging system not working?

Ray
 
Sponsored Links
  #2  
Old 07-16-05, 08:36 AM
Lugnut's Avatar
Member
Join Date: Jan 2001
Location: Kansas City, Missouri.
Posts: 1,172
Occasionally rebuilt alternators are defective right off the shelf. Start your engine, then get a battery voltage reading. It should be at least 13 volts with engine running. If not, then your alternator is bad.
 
  #3  
Old 07-16-05, 04:41 PM
Bubba Bob
Visiting Guest
Posts: n/a
It could also be the fan belt. How long has it been since it's been replaced?
 
  #4  
Old 07-16-05, 04:51 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Your charging system may be working, you may have a drain on the battery
Try Lugnut's test
Test the voltage after the car is shut off
Test the voltage the next morning before you turn the key
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'