1992 Buick Century Limited turn Signal Flasher issue

Reply

  #1  
Old 07-20-05, 06:41 PM
dramaphile
Visiting Guest
Posts: n/a
1992 Buick Century Limited turn Signal Flasher issue

Last week, I hit a pole in a parking lot (the pole was at the driver's side back corner of the car, and I hit the driver's side just before the front bumper, shattering the turn signal cover, crushing in the bumper (which popped back out) and making a small dent in the side of the car in front of the wheel well. The cosmetic damage is pretty minimal.

The turn signal cover has been replaced and the light comes on, but it doesn't flash in the front or the back on the driver's side (the back was not damaged at all). The passenger side turn signal works just fine. I checked the fuse for the turn signal and it looks like it's fine, but I might just not be looking in the right place.

My problem is, I'm not entirely sure where the turn signal flasher is located, so I can't tell if it's damaged, or if it's a fuse problem or what. Can anyone tell me where it might be located and what might possibly be damaged? I'd like to fix this myself (I have help as well, but they're not as familiar with American cars) instead of taking it in to the shop.
 
Sponsored Links
  #2  
Old 07-20-05, 06:45 PM
Member
Join Date: Feb 2005
Location: Michigan
Posts: 335
you probably just need to replace the bulb. If one is messed up the other one on that side wont work right.
 
  #3  
Old 07-20-05, 08:24 PM
dramaphile
Visiting Guest
Posts: n/a
Haha I just figured that out and was about to come delete the thread. Thanks so much for the help though!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes