1996 mercury grand marquis acceleration problem

Reply

  #1  
Old 07-22-05, 02:10 PM
bentley308
Visiting Guest
Posts: n/a
1996 mercury grand marquis acceleration problem

Help...I am having problems with the above vehicle not responding to acceleration attempts. where do i start. I tried to accelerate into trafic and it just did not respond.
It is the 4.6 engine with fuel injection..
 
Sponsored Links
  #2  
Old 07-22-05, 05:05 PM
Member
Join Date: Dec 2001
Posts: 2,538
is the check engine light on if it is you could start by having codes read in the computer.
if it is bogging down or dies out on acceleration you should have fuel pressure checked and if you havent changed the fuel filter within the last 20000 miles you could probably start there.
if its hesitating or missing it is probably an ignition problem plugs or wires or possibly a coil.
 
  #3  
Old 07-23-05, 08:22 AM
bentley308
Visiting Guest
Posts: n/a
Thanks for your response Bejay.
I will start with the filter as I believe this is probably the original and has 50000 miles on it.
I runs pretty smooth at speed once it gets going... no check engine light
thanks again.
 
  #4  
Old 10-02-07, 07:42 PM
Member
Join Date: Oct 2007
Posts: 1
same problem

I have the same problem and can't seem to find the answer...anyone know why we have this acceleration problem...I have new fuel pump and filter...injectors and plugs???
 

Last edited by sheepdog113; 10-02-07 at 07:43 PM. Reason: spelling
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes