unrook battery cable

Reply

  #1  
Old 07-27-05, 06:16 PM
Member
Thread Starter
Join Date: Oct 2003
Location: usa
Posts: 79
unhook battery cable

my truck 96 s 10 4 cyl has had bad gas milage after having it checked and finding nothing but old o2 senors,i replaced them but the truck still gets bad gas milage. i was told to unhook the battery cable for while then rehook it and the system and the new 02 sensors should reset . it this ok to do .thanks andy
 

Last edited by adrew; 07-27-05 at 06:36 PM.
Sponsored Links
  #2  
Old 07-27-05, 06:41 PM
Lugnut's Avatar
Member
Join Date: Jan 2001
Location: Kansas City, Missouri.
Posts: 1,172
The new o2 sensors take effect immediately, regardless of weather or not the computer is reset. At best, disconnecting the battery will turn off the check engine light, but it will go out by itself in short order if it was in fact triggered by the o2 sensors.
 
  #3  
Old 08-07-05, 06:09 PM
Member
Thread Starter
Join Date: Oct 2003
Location: usa
Posts: 79
part brand ?

still no fix HELP ,but i have been told that i should have used ac delco replacement sensors that could be the problem, i used standard part brand.whats your opinion. thanks again
 
  #4  
Old 08-07-05, 06:22 PM
Lugnut's Avatar
Member
Join Date: Jan 2001
Location: Kansas City, Missouri.
Posts: 1,172
Replacement brand sensors are usually fine for american cars. Are you getting o2 sensor codes?
 
  #5  
Old 08-07-05, 06:26 PM
Member
Thread Starter
Join Date: Oct 2003
Location: usa
Posts: 79
part

no but i still get 8-10 miles to the gallon no leaks truck runs fine,i am pulling my hair out.thanks
 
  #6  
Old 08-07-05, 08:50 PM
jeffstevens
Visiting Guest
Posts: n/a
Check the codes, the readers have come down in price.
 
  #7  
Old 08-08-05, 04:16 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,519
Go by an Auto Zone; they'll read it for free.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'