94 Toyota Camry. Starter, AC, Power Windows, and Speedometer Broke

Reply

  #1  
Old 08-04-05, 02:02 PM
tj817tx
Visiting Guest
Posts: n/a
94 Toyota Camry. Starter, AC, Power Windows, and Speedometer Broke

Ok i need help bad. This car runs fine the only problems i have with it are these.

A. The starter takes forever to kick over i have to turn and turn..and here the click...click..click. I work at a Jiffy Lube(quit a few weeks ago) and tested the battery, it read good.

B. Just yesterday I was driving w/my AC on, and it just died..my speedometer needles all went to 0, and my power windows didn't work...i was so hot.

C. I got in a wreck a long time ago and got a new hood, but the safety latch wasn't fixed. The hood latched fine, but it wasn't safety latched if u poped it. I got it fixed on a side job. My dad borrowed my car and the break light comes on faulty, the e-brake is poped but it lights up. He pulled the hood latch and BOOM no hood once again. I've been driving w/no hood for a good month now...would that cause electrical problems? It's rained a few times here.

Please help. My e-mail is [email protected]
 

Last edited by toyotaman11769; 08-06-05 at 12:11 PM. Reason: Spelling
Sponsored Links
  #2  
Old 08-05-05, 04:23 PM
Member
Join Date: Aug 2005
Posts: 161
Originally Posted by tj817tx
Ok i need help bad. This car runs fine the only problems i have with it are these.

A. The starter takes forever to kick over i have to turn and turn..and here the click...click..click. I work at a Jiffy Lube(quit a few weeks ago) and tested the battery, it read good.
If you are positive the battery is good clean the terminals for the wires on the starter and battery terminals. If that doesn't help the starter is bad

B. Just yesterday I was driving w/my AC on, and it just died..my speedometer needles all went to 0, and my power windows didn't work...i was so hot.
you check the fuses and relays to see if you are getting power all the way to the relays coil pins
C. I got in a wreck a long time ago and got a new hood, but the safety latch wasn't fixed. The hood latched fine, but it wasn't safety latched if u poped it. I got it fixed on a side job.
thanks for sharing

My dad borrowed my car and the brake light comes on faulty, the e-brake is poped but it lights up.
The parking brake shares the brake light disconnect the parking brake light switch and see if that helps. If not you have brake pressure issues
He pulled the hood latch and BOOM no hood once again. I've been driving w/no hood for a good month now...would that cause electrical problems? It's rained a few times here.
Was it an ejecting hood latch ????????????????????????????????????????????????????

Please help. My e-mail is [email protected][/QUOTE]
 

Last edited by toyotaman11769; 08-06-05 at 12:17 PM.
  #3  
Old 08-06-05, 05:25 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
Note on the starter: the contacts in the solenoid portion of the starter are replaceable at a fraction the cost of a replacement unit and they are what usually goes. Very unusual for a Toyota starter itself to go bad.
 
  #4  
Old 08-06-05, 12:20 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Gauge fuse blown.......common for wires to break at drivers side trunk hindge where they meet the main harness and short.
 
  #5  
Old 08-06-05, 12:25 PM
tj817tx
Visiting Guest
Posts: n/a
?!?!?

i checked the fuses....they seem clean? What do they look like if blown? also someone said my starting up problem could be my ignition switch?


p.s. - I have read somewhere about a 96 Grand Prix having the same problem as me. The person said it was his Body Control Moduel? Maybe that's my problem? where is this located?
 
  #6  
Old 08-06-05, 01:15 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
The gauge fuse is located behind the cover on the left side dash.
 
  #7  
Old 08-06-05, 02:20 PM
tj817tx
Visiting Guest
Posts: n/a
Sorta Fixed

Sorta Fixed, how the fuse blows everytime I press the a/c button. If I leave it off and just let the fan blow air from outside it doesn't blow....any suggestions?
 
  #8  
Old 08-06-05, 03:07 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Hey, thanks for the help. It was the Gauge fuse, now there is another problem. I put in the spare fuse that was under the hood of the car where other fuses are for the engine. I starter the car up, and the stuff worked shortly and POW died again. This time I turned the ac off, and just left the fans on. I bought a box of the (10a/10) fuse I think. I put a 3rd one in, and once again back 2 life. This time it didn't die....right when I priessed the a/c button it died after 1-2 secs of flickering lights on the a/c control dash. What do you think the problem is? I have also had problems with the a/c b4. It would sometimes go squeeeeeeeeeeel when I turned the a/c on. The little rotar/barring i thing? would be wobbling like crazy while spinning. It wasn't spinning like normal...like wobbaly. heeeeelp haha. oh and about the starter thing what's your take?
The A/C clutch is your problem, most likely damaged from the accident (usually the A/C clutch hits the frame rail)
 
  #9  
Old 08-06-05, 03:13 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Forgot about the starter....take towguys advice or buy a new starter
 
  #10  
Old 08-06-05, 07:28 PM
tj817tx
Visiting Guest
Posts: n/a
problems b4 accident

Well that was my First accident. A/C has worked since then, I also got into another fender bender...and the a/c still worked. It worked fine up until 2-3 days ago when the fuse blew and everything died.
 
  #11  
Old 08-07-05, 05:08 AM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
I have also had problems with the a/c b4. It would sometimes go squeeeeeeeeeeel when I turned the a/c on. The little rotar/barring i thing? would be wobbling like crazy while spinning. It wasn't spinning like normal...like wo
That part thats wobbling is the a/c clutch and thats whats blowing the fuse
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:58 AM.