No Speedometer or Mileage

Reply

  #1  
Old 08-06-05, 10:39 PM
Old man
Visiting Guest
Posts: n/a
Unhappy No Speedometer or Mileage

I have an 86' Cougar, 3.8l engine, automatic trans.
The problem is with the speedometer and mileage readout, it is a digital unit.
I have replaced all the lightbulbs in the dash and it backlites just fine. But will display no numbers in the mileage or speedo. I have had it all apart trying to figure this out, it appears the readout itself is an LCD unit that connects to the circuit board with ribbon wire typ connectors. I have looked over the circuit board for obvious bad components and can spot nothing. It lights up a solid green, and has a few lighter green speckles in there.

Anyone know anything about these? I am finding almost no info on these units, seem like they are top secret or somthing.

Any info will be appreciated, as speeding tickets are expensive.
Thanks,
Mike
 
Sponsored Links
  #2  
Old 08-06-05, 11:57 PM
Eddiebx
Visiting Guest
Posts: n/a
try taking a look at the vehicle speed sensor maybe that is loose or dead
 
  #3  
Old 08-07-05, 12:29 AM
Old man
Visiting Guest
Posts: n/a
I thought about that,but that should not keep the total mileage from showing, should it? When the car is moving I know the speed sensor should tell it what numbers to change to, but it is not even displaying '0' when sitting still, it is just blank.
I cannot find any info on this stuff, Ford just says they have to send them out for repair if there is any problems with them, and quite frankly the repair will probably cost more than the car is worth.
I can't find any schematics or voltage references for the speedometer circuit at all.

Thanks,
Mike
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'