Emissions Code, 2000 Taco

Reply

  #1  
Old 08-08-05, 02:57 PM
mako's Avatar
Member
Thread Starter
Join Date: Jan 2002
Location: Wake Forest
Posts: 455
Emissions Code, 2000 Taco

2000 Tacoma, 81K miles, 2.4l 4-banger, 5spd, fresh oil two weeks ago. 89 Octane, clean-ish air filter.
Code is P0420, "Catalyst System Efficiency Below Threshold Bank 1".

Did this same thing almost exactly a month ago, but was running fine. I erased to the code to see if it would come back or if it was just a burp of some sort in the exhaust system. Came back just today.

I'm not a mechanic but know a lil, and just happen to have a pocket code scanner. I know this thing is telling me something is up with my cat, but what exactly am I supposed to do about it? There's two codes for this exact same description and two codes for "Bank 2", so in addition to what's going on with my truck, what is the difference between these 4 codes?

Any help is greatly appreciated. I've never had problem one with this truck, so I'm a bit befuddled.
 
Sponsored Links
  #2  
Old 08-09-05, 02:08 AM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
The cats not working....possibly had a dirty air filter at onetime?

Try running the hell out of it in 2nd gear to get the cat good and hot.

Clear code and see what happens.

BTW 89 oct no good, designed for 87. Computer assumes 87 and will not burn 89 or higher as complete.
 
  #3  
Old 08-09-05, 03:32 PM
mako's Avatar
Member
Thread Starter
Join Date: Jan 2002
Location: Wake Forest
Posts: 455
Thanks for the octane info, I actually do run 87 octane I just goofed with the typo.

I'd already cleared the code, but it did nothing on the way to and from work today (20 miles, half of which stop and go, half 55mph).

Is this something I need to take to a pro and have checked out, or should I wait for it to become consistent?
 
  #4  
Old 08-13-05, 04:31 PM
mako's Avatar
Member
Thread Starter
Join Date: Jan 2002
Location: Wake Forest
Posts: 455
The same code came up today, was doing about 50 in 5th gear. What am I supposed to do? Is this a "replace the cat" kind of thing?
 
  #5  
Old 08-15-05, 04:25 PM
mako's Avatar
Member
Thread Starter
Join Date: Jan 2002
Location: Wake Forest
Posts: 455
Anybody? I am getting the code on a daily basis now. P0240. What am I supposed to do to this truck?
 
  #6  
Old 08-15-05, 04:55 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Yes you are going to need to replsace the cat. It is covered for 80,000 miles. If you are a good customer at the dealer they may work with you.
 
  #7  
Old 08-16-05, 04:09 PM
mako's Avatar
Member
Thread Starter
Join Date: Jan 2002
Location: Wake Forest
Posts: 455
Thanks Toyotaman. I'll be contacting the dealership soon. They've been good to me so far.

Matt
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'