E150 1985 help with fuel filter or other diagnosis

Reply

  #1  
Old 08-28-05, 04:10 PM
willhags
Visiting Guest
Posts: n/a
E150 1985 help with fuel filter or other diagnosis

My Econoline bit the dust so to speak after i hit a huge puddle of water got up in the engine, but it still starts and revs/idles fine. When I put her in drive/reverse and can go a bit with no probs until i give her too much gas and she tries/does die on me. i thought maybe fuel filter...blew a spark plug... water in carb(unlikely)... or water got inside the muffler via to the engine and i am screwed...will someone help me at least find the damn fuel filter??? thanks..
 
Sponsored Links
  #2  
Old 08-28-05, 04:31 PM
willhags
Visiting Guest
Posts: n/a
to those who might read this...i need a reply. asap...thank you...
 
  #3  
Old 08-28-05, 06:41 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Originally Posted by willhags
...will someone help me at least find the damn fuel filter??? thanks..
You don't say what engine
But I think on both the 302 and 300 you follow the fuel line from the carb to behind the alt you should find it

Restarts OK after it dies on you?
Doesn't seem like it's flooded? Hard to re-start?
 
  #4  
Old 08-28-05, 07:48 PM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
pull cap

Pull distributer cap it might have moisture in it.
 
  #5  
Old 08-30-05, 05:37 PM
willhags
Visiting Guest
Posts: n/a
Quote:
Originally Posted by willhags
...will someone help me at least find the damn fuel filter??? thanks..

You don't say what engine
But I think on both the 302 and 300 you follow the fuel line from the carb to behind the alt you should find it

Restarts OK after it dies on you?
Doesn't seem like it's flooded? Hard to re-start?

slickshift
View Public Profile
Send a private message to slickshift
Find all posts by slickshift
Add slickshift to Your Buddy List

#4 08-28-05, 10:48 PM
michael van
Members Join Date: Nov 2001
Posts: 1,082

pull cap

--------------------------------------------------------------------------------

Pull distributer cap it might have moisture in it.

------------------------ it is a little tough to restart after it stalls...but now it sits and starts right up. i gave her a tune up plugs an all,,, pulled the distributer cap cleaned it up(nice an dry) and test ran got her up to 55 and she bogged out on me i slowed down and tried a u turn through it in reverse and stalled...started back up and made it home slow(35mph) i'll try that looking for the feul filter tmw.thought of trying these yhings first and failed.we shall see what happens tmw.. thanks guys...anything else??
 
  #6  
Old 08-30-05, 06:11 PM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
yep

Bogs at high rpm does sound like fuel filter do not know were it is on your van but if you go to autozone and get one they can look it up.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:14 AM.