4WD Quit on my 95 GMC Jimmy

Reply

  #1  
Old 09-07-05, 11:31 AM
Member
Thread Starter
Join Date: Feb 2005
Posts: 24
4WD Quit on my 95 GMC Jimmy

I've just discovered that the 4wd just quit working on my 95 Jimmy (small S-10 size Blazer). I checked the 20A fuse for the 4wd and it is good. This is the push button on the dash kind of 4wd control. When I push the 4wd high button the light comes on, but the 4wd does not engage. The vehicle will shift into low range at the rear wheels but no power to the frt wheels. Any suggestions for a low cost fix, as I'm trying to trade this vehicle in at a local dealer???
 
Sponsored Links
  #2  
Old 09-07-05, 07:26 PM
Member
Join Date: Feb 2005
Posts: 579
What the dealer don't know, won't hurt them, right?
It sounds like you may have a bad vacuum line going to the actuator, under the battery. Or, the actuator itself is bad. We see alot of these come in and have had battery acid leak down on the actuator, which eats the rubber away. You will need to remove the battery and the battery tray to visually inspect the actuator, and to make sure you have the vacuum hose connected. Follow that vacuum hose up to the passenger side of the engine compartment, back down on top of the transfer case. Make sure it's not melted, broke, or deteriated. If everything looks good, start the truck and check for vacuum from that hose before it goes into the actuator. If there is no vacuum, I would suspect the vacuum switch on top of the transfer case is bad. Good luck and let us know the outcome.
 
  #3  
Old 09-09-05, 10:17 AM
Member
Thread Starter
Join Date: Feb 2005
Posts: 24
The vacuum actuator under the battery fixed it all up. But not cheap, the new part was only available from my local chevy dlr and they ripped me for $87 plus tax. But it's fixed and I guess that's the important part. Thanks for your helpful opinion.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'