code po420 anybody got answer

Reply

  #1  
Old 09-24-05, 04:39 PM
Member
Thread Starter
Join Date: Dec 2004
Location: OHIO
Posts: 32
code po420 anybody got answer

have a 98 chevy silverado 4x4 anybody know what this code means po420 catalst system below threshold left bank dont really know what that is. i was thinking oxygen sensor but the book list 22 seperate codes for the oxygen sensor thier is 4 oxygen sensors on truk 2 on each side.any help appreciated ty sledge 312000 miles on truck
 

Last edited by SLEDGEHAMMER; 09-24-05 at 04:58 PM.
Sponsored Links
  #2  
Old 09-24-05, 05:29 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
It means the cat is not working.

Could be anything that effects the fuel/air mixture. Could be as simple as a dirty air filter. Could be the o2 sensor before that cat, Dirty fuel injectors, dirty mass air sensor etc.

It will not be the sensor after the cat. How that code is set is if the after sensor mimics the before sensor it shows the cat is not performing
 
  #3  
Old 09-25-05, 02:08 PM
Member
Thread Starter
Join Date: Dec 2004
Location: OHIO
Posts: 32
ty for info

thanks for info i checked maf sensor it looked clean filter was a little dirty got some fuel injector cleaner in tank truk doesnt have hesitation any more will see if light reappaers or not i also have a 89 corrola with 260000 miles best car i ever had no problems except basics brakes exhaust ect. my next vehichle will be a used tacoma with a 4 cylinder with gas prices i think thats all i will ever buy again i the big 4 ty for info sledge
 
  #4  
Old 09-25-05, 05:54 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Just to clarify, the poor A/F mixture, etc is the root cause. Correcting that may bring the cat backÖ.if not it needs to be replaced.
 
  #5  
Old 09-26-05, 10:14 AM
Member
Join Date: Dec 2004
Posts: 23
code 420

I had the some code on my little ford. I drove the thing for months like it untill the exhaust line broke off on the front of the CAT. I don't know if the cat was plugged and the extra weight did it in but once I put on the aftermarket cat the code cleared itself and has stayed away.
Nifty
 
  #6  
Old 10-15-05, 05:32 PM
Member
Thread Starter
Join Date: Dec 2004
Location: OHIO
Posts: 32
code 420 any help apprcieated

code po 420 showing up on scan 2 converters on truck 98 silverado 4x4 1500 5.7 315000 miles truck runs good no problems just service engine soon light comeing on showing po 420 im pretty sure from what ive been told that sensors have thier own codes so is it looking like converters are bad? any help apprciated ty sledge
 
  #7  
Old 10-15-05, 05:47 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
I think we went over this already:
http://forum.doityourself.com/showthread.php?t=233219
 
  #8  
Old 10-15-05, 05:52 PM
Member
Thread Starter
Join Date: Dec 2004
Location: OHIO
Posts: 32
converter

i think thats probbally the problem nifty ive tried other things and code keeps comeing up converters will be next is thier any test that can be ran to check them ty sledge
 
  #9  
Old 10-15-05, 05:56 PM
Member
Thread Starter
Join Date: Dec 2004
Location: OHIO
Posts: 32
toyotaman

sorry man just trying to figure this out wont post anymore until i learn more about computers and this site sledge
 
  #10  
Old 10-15-05, 06:00 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
You donít have to apologize, but to correct your problem the cats need to be replaced
 
  #11  
Old 10-18-05, 02:39 PM
Member
Thread Starter
Join Date: Dec 2004
Location: OHIO
Posts: 32
converter repl.

thanks for info thats what i am going to do now .will it hurt motor to drive it like it is until i get them replaced. i plan on getting it done in next month or so . ty guys sledge
 
  #12  
Old 06-07-09, 08:51 AM
Member
Join Date: Jun 2009
Posts: 1
Well I have a 1996 Chevy that is getting the same code. I have changed all 4 O2 sensors and both cats and still get the code I do hear an exhaust leak and am going to fix that next since it would through the sensing out of wack.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:21 PM.