1996 z71 truck headlights possessed

Reply

  #1  
Old 10-24-05, 11:39 AM
repbuddy
Visiting Guest
Posts: n/a
Unhappy 1996 z71 truck headlights possessed

My 96 z71 has decided that the lights will only work when the switch is in the fog light position. What's strange is that the headlights work in this position. The daytime running lights should be on in this position along with the fog lights I would think. The headlights can not be put on bright. When you turn the switch all the way to the on position all of the lights go off except for one day time running light. All of the bulbs work in one of the above positions but never all together. I changed out the light switch module witch included a dome override and also a bezel light dimmer switch. This didn't solve the problem. I'm confused, could the bright on/off switch cause this itself?
 
Sponsored Links
  #2  
Old 10-26-05, 07:38 AM
BuzzCut
Visiting Guest
Posts: n/a
Sounds like the multi-function switch may be at fault. If GM does the same crap as Ford by running the Fogs through the switch instead of using a relay it heats up this thing so over time it goes out. Get it checked and you will find out it is shot.




Originally Posted by repbuddy
My 96 z71 has decided that the lights will only work when the switch is in the fog light position. What's strange is that the headlights work in this position. The daytime running lights should be on in this position along with the fog lights I would think. The headlights can not be put on bright. When you turn the switch all the way to the on position all of the lights go off except for one day time running light. All of the bulbs work in one of the above positions but never all together. I changed out the light switch module witch included a dome override and also a bezel light dimmer switch. This didn't solve the problem. I'm confused, could the bright on/off switch cause this itself?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'