91 Chev Beretta ....fuel or sensor?

Reply

  #1  
Old 11-18-05, 01:36 PM
Member
Thread Starter
Join Date: Nov 2005
Posts: 12
91 Chev Beretta ....fuel or sensor?

Hi all I am new here, and am at wits end with my problem, so gonna try here to see if someone can give me any ideas.

I have a 91 Chev Beretta with a 3.1 v-6. I started it the other day with no problem, drove to a couple places, was fine. Last place I went to start it, it started up real rough, put it in reverse and it died. Thinking maybe i had my foot on gas pedal while reading mail...put pedal to floor and tried to start it thinking was flooded.Nope.Gave it a few minutes, tried again, and no luck. Did this 2 more times, and car would start, but more I tried to keep it running, would overdo it and it would die. Towed it home, and wont even try to start now when it did before. Just turns over..but not fire. Have replaced the ICM, 2 coils,fuel filter and pump,knocked out cat converter and ran straight pipe (converter was collapsed, live in Alaska..no emissions), 02 Sensor, and TPS...and computer comes up with no error codes. This all has been replaced in the last 4 months...any ideas?

Any help would be greatly appreciated...thanks in advance
 

Last edited by jenacus2; 11-23-05 at 12:31 AM.
Sponsored Links
  #2  
Old 11-20-05, 07:28 PM
Member
Thread Starter
Join Date: Nov 2005
Posts: 12
Problem solved (I think)..motor wasnt getting fuel, so had friend pull fuel pump to make sure was working. Pumping strong, so he put it back in. Checked for fuel to motor..and was there. Now question is..is it possible to have it plug up right at pump instead of at the filter?

1991 Chev Beretta 3.1 V-6 Auto
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes