95 Ford Contour-idling slow.

Reply

  #1  
Old 11-25-05, 08:25 PM
Square Head's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Winnipeg MB, Canada.
Posts: 188
Exclamation 95 Ford Contour-idling slow.

My Contour has a 2.0 z-tec engine. Once it has warmed up and the high idle comes off, it idles way too slow. Some times stalling at red lights and when I back up.
Spark plugs are new.
Coil pack and ignition wires are new.
Air filter is new.
Just did the timing belt as well.

Could it be the PCV or EGR valve is malfunctioning?

Thanks.
 
Sponsored Links
  #2  
Old 11-28-05, 06:04 AM
Member
Join Date: Oct 2000
Location: Livonia, Michigan
Posts: 923
Try cleaning the throttle body bore. With use, the bore gets a buildup of carbon around the butterfly valve which messes up the idle. To clean, remove the throttle body and clean the bore and butterfly valve using carb cleaner (or throttle body cleaning spray) and a toothbrush. You'll have to work at it...the stuff is hard to get off. When clean, you should see an even gap of air around the butterfly valve. While you're at it, clean the idle air control motor. Disconnect the battery for a minute afterwards, to force the computer to relearn the new idle parameters with the clean throttle body.

Or it could be a bad EGR valve with deposits not allowing it to close properly. This will also mess up the idle to the point of stalling.
 
  #3  
Old 11-28-05, 06:28 PM
Square Head's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Winnipeg MB, Canada.
Posts: 188
No-no

It specifically states not to use these types of products on or in the valve body.
It will eat the coating off in the bore. Have you done this before?
Is there a product that won't damage the coating?
 
  #4  
Old 11-29-05, 05:44 AM
Member
Join Date: Oct 2000
Location: Livonia, Michigan
Posts: 923
If the coatings were all that great we wouldn't need to clean the throttle body bore.

Yes, they make solvents that are safe for coated throttle bodies, but I'm not willing to spend extra for that product. I'm guessing the coating makes it a little easier to shed deposits... I simply work at it a bit harder with the toothbrush.

One thing you need to be careful with is to make sure the product is safe for the O2 sensor. Silicon-based products such as silicone can poison the sensor. I don't know which products are harmful, but I can bet that gasoline or kerosene are safe solvents to use.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'