1995 Chevy van 4.3l v-6 rough idle, hard to start

Reply

  #1  
Old 11-28-05, 05:20 AM
CMil's Avatar
Member
Thread Starter
Join Date: Apr 2002
Location: United States of America
Posts: 432
1995 Chevy van 4.3l v-6 rough idle, hard to start

Going to try this one again. I'm working on a '95 Astro van with the 4.3 Vortec engine. Symptoms are: hard cold starting, rough idle, low vacuum (15" at idle), and DTC 32. Changing a few questionable vacuum hoses and resetting ignition timing (it's got the distributor, not the HVS) hasn't really changed anything. Code 32 points to the EGR system/circuit; what are the odds the EGR valve is hanging open? Also, what is the coil/motor-actuated vane device stuck in the top of the upper intake plenum? I'm a little new to this engine and have never seen anything like this on any other engine in my life. Something to do with fuel mileage, emissions, or performance? Anyway, thanks in advance for any/all advice/input. - Chris
 
Sponsored Links
  #2  
Old 11-28-05, 08:12 PM
Member
Join Date: Apr 2003
Posts: 174
Remove your EGR and look at the pindle, it will have a chunk of carbon holding it open, know problem with this motor. Clean it out and put it back on. If you want, they make a gasket for it that includes a small screen for to keep the carbon chunks out. I clean out my EGR every oil change, takes 10 min.
 
  #3  
Old 11-29-05, 04:21 AM
CMil's Avatar
Member
Thread Starter
Join Date: Apr 2002
Location: United States of America
Posts: 432
Thanks, Cabot. Seems like that may have been the problem. When I took the valve off, the pintle was seated in the closed position, and moved back and forth fairly easily. However, when I gently pushed it all the way through its travel, it DID stick wide open. No amount of tapping on the pintle, stem or valve body was going to un-stick it, but a gentle pry on the backside of the pintle worked it loose again. After working the valve a little more and cleaning out the chamber, I put the valve back on, started and warmed the engine, and it seems to run fine. I want to check codes and vacuum again, but I can do that when I get the van back for radiator hoses, thermostat and coolant service in a couple of weeks. Thanks again for your input. - Chris
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes