Ford C6 Transmission Problem

Reply

  #1  
Old 11-28-05, 08:21 PM
lf8828
Visiting Guest
Posts: n/a
Ford C6 Transmission Problem

MY TRANSMISSION WORKS FINE IN REVERSE BUT IT SEEMS TO BE IN BOTH FORWARD AND REVERSE IN THE FORWARD GEARS. THE ONLY WAY IT WILL MOVE IS IN DRIVE, 1ST AND 2ND SEEMS TO BE IN REVERSE ALSO. I JUST CHANGED THE VALVEBODY OUT LAST WEEK THEN THIS HAPPENED. ANYONE THAT CAN HELP WILL BE MUCH APPRECIATED.
 
Sponsored Links
  #2  
Old 11-30-05, 12:43 PM
Member
Join Date: Aug 2005
Location: Michigan
Posts: 229
Did you use all of the original linkage from the original valve body? Why did you change the valve body and was the valvebody a "good used one" or did somebody "rebuild" it? Ford has Many linkage configurations for these and it is important to use the original linkage when ever possible. It sounds to me if I understand you correctly that it is cross feeding reverse and forward at the same time, if this is the case and you continue to drive it it will take its toll on the clutches inside. Can you switch to the original valvebody just to see if the problem goes away? Just a thought.
Jeff
 
  #3  
Old 12-03-05, 08:07 AM
lf8828
Visiting Guest
Posts: n/a
ford c6 trans trouble

we did swap it back and the same problem is still there. we had installed a reverse manual valvebody for drag racing . we race this truck in the mud drags. i beleive it welded the clutches together in the trans. i built the motor up more and the stock trans wouldnt handle the extra power. thanks for the info.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'