1996 Geo Metro EGR

Reply

  #1  
Old 12-10-05, 11:34 PM
Jamesisit
Visiting Guest
Posts: n/a
Lightbulb 1996 Geo Metro EGR

My Metro has had a ongoing thing with the EGR system, I thought I would pass this by everyone.
Two years ago I started getting a Check engine light. I have a code tool so what I get is EGR flow malfunction. This usually happens after cruseing on the highway for a while then as I slow down on the exit ramp about the time the Automatic transmission down shifts from 3rd to 2nd the light comes on. My understanding is that this is the Second time the computer sees this and after the second time it sets the Check engine light.
Now, here is what I've done...
Replaced the EGR valve, Replaced the EGR vacuum solonoid, replaced the two vacuum switches for the EGR. Replaced all the vacuum lines on the motor. Cleaned out the Engine EGR passages to the best of my ability without taking the motor out.
Don't really know what else to do. What say you?
 
Sponsored Links
  #2  
Old 12-11-05, 01:40 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Good chance the EGR sensor is bad if no other problems are present.
 
  #3  
Old 12-11-05, 02:46 PM
Jamesisit
Visiting Guest
Posts: n/a
Thanks but..

The two "switches" I refered to as replaced are what does that. Next suggestion?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'