1996 Mercury marquises turn signal

Reply

  #1  
Old 12-20-05, 11:36 AM
Member
Thread Starter
Join Date: Dec 2003
Posts: 17
1996 Mercury marquises turn signal

Having a problem with my 1996 Mercury marquises turn signal. If I engage the turn signal completely(left or right turn) where it will automatically return to neutral position. It doesn't work! If I engage the turn signal partially where the Arrow on the panel is just illuminated and blinking it works fine. The owner's manual shows the plug-in Flasher located under the dashboard with the fuses. But it's not their, just a vacant slot. Had local mechanic check , and he indicated the Flasher was located in a separate module that cost close to $350. Since the turn signal works when I do not completely engaged it , could it be something other than this expensive module?

Thank you.
 
Sponsored Links
  #2  
Old 12-20-05, 11:47 AM
chevyastro4x4's Avatar
Member
Join Date: Jan 2005
Location: Watertown
Posts: 592
sounds like the switch in the steering wheel, does your car have air bags? if it does i would remove the steering wheel and get a closer look at the switch to make sure the two metal stips are touching when the switch is fully engaged.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'