2000 Mercury Sable Stationwagon

Reply

  #1  
Old 12-27-05, 06:37 AM
Johnfred
Visiting Guest
Posts: n/a
2000 Mercury Sable Stationwagon

Persistent coolant smell. Have a 2000 Sable Wagon w/ six cylinder engine. Vehicle has 55,000 miles and for the past twenty four months has been plagued with the unmistakable odor of leaking coolant.
There is no spotting underneath the vehicle when parked overnight.
I've been advised the manufacturer replaced head gasket under warranty via the dealer at an early age. The owner replaced a head gasket with the same dealer after warranty expired. The coolant tank leaked and was also replaced along with the tube running from the coolant tank to the radiator. I'm told it was rusted out??? The radiator was also replaced by the dealer.
The oil level does not increase nor does the oil appear to foam after operation. Odor is apparent when the vehicle stops after operation.
Half to three quarters of a gallon of coolant need to be added to the tank/reservoir approximately monthly in order to bring the coolant level up to the prescribed tank indicator line.
Car does not overheat. Heater and de-frost operate properly.
Any suggestions as to where is the coolant going? Or what's going on? Dealer is suggesting head gasket again...(They don't make them as well any more.)
Perplexed in Detroit, viewing Toyota or Mazda...
Johnfred
 
Sponsored Links
  #2  
Old 12-27-05, 02:04 PM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
questions

Do your windows fog up?also check carpet on passanger side for moisture.If so heater core is faulty.
I know what you mean by not making them like the old days.I have a 2000 ford Taurus now sister to your car and I am scared to drive the thing because something might fail (knock on wood)
I also have a two Toyotas and not a lick of problems with them makes me wonder why The big three just cant get it togeather.
Anyway let me know what comes up as I am very intrested since I have same type car Oh I forgot do you have the 3.0 engine or the problem 3.8?
 

Last edited by michael van; 12-27-05 at 02:05 PM. Reason: forgot
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'